Break Standard Weight ZOJ – 3706

作者: qwq 分类: ACM 发布时间: 2017-04-15 21:41

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term “scales” for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

InputThere are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 鈮?x, y 鈮?100

OutputFor each test case, output the maximum number of possible special masses.

Sample Input

2
4 9
10 10

Sample Output

13
9

这个题目也很简单,一共只有14种情况,所以暴力穷举就可以。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int s[300]={0};
int main(){
int n,a[3];
cin>>n;
while(n--){
        int sum=0,sumx=0;

    int x,y;
    cin>>x>>y;
    for(int i=0;i<=x/2;i++){
            memset(s,0,sizeof(s));
        sumx=0;
        a[0]=i;
        a[1]=x-i;
        a[2]=y;
        sort(a,a+3);
    s[a[0]]=s[a[1]]=s[a[2]]=s[a[1]-a[0]]=s[a[1]+a[0]]=s[a[2]-a[1]]=s[a[2]-a[0]]=s[a[2]+a[0]]=s[a[2]+a[1]]=s[a[2]+a[0]+a[1]]=s[a[2]+a[0]-a[1]]=s[a[2]+a[1]-a[0]]=1;
    if(a[2]-a[1]-a[0]>0){
        s[a[2]-a[1]-a[0]]=1;
    }
    if(a[0]+a[1]-a[2]>0){
        s[a[0]+a[1]-a[2]]=1;
    }
    for(int j=1;j<300;j++){
        sumx+=s[j];
    }
if(sumx>sum){
    sum=sumx;
}
    }


for(int i=0;i<=y/2;i++){
        memset(s,0,sizeof(s));
        sumx=0;
        a[0]=i;
        a[1]=y-i;
        a[2]=x;
        sort(a,a+3);
    s[a[0]]=s[a[1]]=s[a[2]]=s[a[1]-a[0]]=s[a[1]+a[0]]=s[a[2]-a[1]]=s[a[2]-a[0]]=s[a[2]+a[0]]=s[a[2]+a[1]]=s[a[2]+a[0]+a[1]]=s[a[2]+a[0]-a[1]]=s[a[2]+a[1]-a[0]]=1;
    if(a[2]-a[1]-a[0]>0){
        s[a[2]-a[1]-a[0]]=1;
    }
    if(a[0]+a[1]-a[2]>0){
        s[a[0]+a[1]-a[2]]=1;
    }
    for(int j=1;j<300;j++){
        sumx+=s[j];
    }
if(sumx>sum){
    sum=sumx;
}
    }

cout<<sum<<endl;



}
return 0;
}

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注