The Suspects ZOJ – 1789 (并查集)

作者: qwq 分类: ACM 发布时间: 2017-04-24 09:54

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n-1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

这道题也是基本的并查集算法,首先读入一个group的学生的编号,然后merge一个group的各个学生。

之后就是从0遍历,如果学生0和某个学生的father节点一样,sum就++;最后输出就可以了。

 

 

#include<iostream>
using namespace std;
struct stu{
	int num;
	int father;
	int is_ok;
	
}stud[30010];
int find(int x){
	while(stud[x].father!=x)
	x=stud[x].father;
	return x;
}
void merge(int a,int b){
	int ra=find(a);
	int rb=find(b);
	stud[rb].father=ra;
	return ;
}
int main(){
	int m,n;
	ios::sync_with_stdio(false);
	while(cin>>m>>n&&(m||n)){
		for(int i=0;i<=m;i++){
			stud[i].father=i;
			stud[i].is_ok=0;
		}
		for(int i=0;i<n;i++){
		int a,b,c;
		cin>>a;
		if(a){
			cin>>b;
			stud[b].is_ok=1;
			for(int j=1;j<a;j++){
			cin>>c;
			stud[c].is_ok=1;
			merge(b,c);
			b=c;
			}
			
		}
			
		}
		int sum=1;
		for(int i=1;i<=m;i++){
			if(stud[i].is_ok==1&&find(0)==find(i)){
				sum++;
				//cout<<i<<" ";
			}
			
		}
		//cout<<find(99)<<" "<<find(0);
		cout<<sum<<endl;
		
	} 
	
	
return 0;	
}

 

2条评论
  • 美丽的小哞

    2017年8月23日 下午2:34

    wtf?

    1. zqqian

      2017年8月23日 下午2:54

      肿么了?

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注