Applications ZOJ – 3705

作者: qwq 分类: ACM 发布时间: 2017-04-15 21:32

 

Recently, the ACM/ICPC team of Marjar University decided to choose some new members from freshmen to take part in the ACM/ICPC competitions of the next season. As a traditional elite university in ACM/ICPC, there is no doubt that application forms will fill up the mailbox. To constitute some powerful teams, coaches of the ACM/ICPC team decided to use a system to score all applicants, the rules are described as below. Please note that the score of an applicant is measured by pts, which is short for “points”.

1. Of course, the number of solved ACM/ICPC problems of a applicant is important. Proudly, Marjar University have a best online judge system called Marjar Online Judge System V2.0, and in short, MOJ. All solved problems in MOJ of a applicant will be scored under these rules:

    • (1) The problems in a set, called MaoMao Selection, will be counted as 2.5 pts for a problem.
    • (2) The problems from Old Surgeon Contest, will be counted as 1.5 pts for a problem.

There is no problem in MaoMao Selection from Old Surgeon Contest.

  • (3) Besides the problem from MaoMao Selection and Old Surgeon Contest, if the problem’s id is a prime, then it will be counted as 1 pts.
  • (4) If a solved problem doesn’t meet above three condition, then it will be counted as 0.3 pts.

2. Competitions also show the strength of an applicant. Marjar University holds the ACM/ICPC competition of whole school once a year. To get some pts from the competition, an applicant should fulfill rules as below:

  • The member of a team will be counted as 36 pts if the team won first prize in the competition.
  • The member of a team will be counted as 27 pts if the team won second prize in the competition.
  • The member of a team will be counted as 18 pts if the team won third prize in the competition.
  • Otherwise, 0 pts will be counted.

3. We all know that some websites held problem solving contest regularly, such as JapanJam, ZacaiForces and so on. The registered member of JapanJam will have a rating after each contest held by it. Coaches thinks that the third highest rating in JapanJam of an applicant is good to show his/her ability, so the scoring formula is:

Pts = max(0, (r – 1200) / 100) * 1.5
Here r is the third highest rating in JapanJam of an applicant.

4. And most importantly – if the applicant is a girl, then the score will be added by 33 pts.

The system is so complicated that it becomes a huge problem for coaches when calculating the score of all applicants. Please help coaches to choose the best M applicants!

InputThere are multiple test cases.

The first line of input is an integer T (1 鈮?T 鈮?10), indicating the number of test cases.

For each test case, first line contains two integers N (1 鈮?N 鈮?500) – the number of applicants and M (1 鈮?M 鈮?N) – the number of members coaches want to choose.

The following line contains an integer R followed by R (0 鈮?R 鈮?500) numbers, indicating the id of R problems in MaoMao Selection.

And then the following line contains an integer S (0 鈮?S 鈮?500) followed by S numbers, indicating the id of S problems from Old Surgeon Contest.

The following line contains an integer Q (0 鈮?Q 鈮?500) – There are Q teams took part in Marjar University‘s competition.

Following Q lines, each line contains a string – team name and one integer – prize the team get. More specifically, 1 means first prize, 2 means second prize, 3 means third prize, and 0 means no prize.

In the end of each test case, there are N parts. In each part, first line contains two strings – the applicant’s name and his/her team name in Marjar University‘s competition, a char sex – M for male, F for female and two integers P (0 鈮?P 鈮?1000) – the number of problem the applicant solved, C (0 鈮?C 鈮?1000) – the number of competitions the applicant have taken part in JapanJam.

The following line contains P integers, indicating the id of the solved problems of this applicant.

And, the following line contains C integers, means the rating for C competitions the applicant have taken part in.

We promise:

  • The problems’ id in MaoMao Selection, Old Surgeon Contest and applicant’s solving list are distinct, and all of them have 4 digits (such as 1010).
  • All names don’t contain spaces, and length of each name is less than 30.
  • All ratings are non-negative integers and less than 3500.

OutputFor each test case, output M lines, means that M applicants and their scores. Please output these informations by sorting scores in descending order. If two applicants have the same rating, then sort their names in alphabet order. The score should be rounded to 3 decimal points.

Sample Input

1
5 3
3 1001 1002 1003
4 1004 1005 1006 1007
3
MagicGirl!!! 3
Sister's_noise 2
NexusHD+NexusHD 1
Edward EKaDiYaKanWen M 5 3
1001 1003 1005 1007 1009
1800 1800 1800
FScarlet MagicGirl!!! F 3 5
1004 1005 1007
1300 1400 1500 1600 1700
A NexusHD+NexusHD M 0 0


B None F 0 0


IamMM Sister's_noise M 15 1
1001 1002 1003 1004 1005 1006 1007 1008 1009 1010 1011 1012 1013 1014 1015
3000

Sample Output

FScarlet 60.000
IamMM 44.300
A 36.000

这个题很简单,也不需要什么算法,就是规则多了一点,我是用的STL里面的map,但是在排序的时候遇到了一点小问题。

如果用其他的数据结构应该也可以

#include<iostream>
#include<bits/stdc++.h>
#include<vector>
#include<map>
using namespace std;
//

typedef pair<string, double> PAIR;
int cmp(const PAIR &x, const PAIR &y)
{
return x.second > y.second;
}
//


int is_p(int i){
for(int j=2;j<i;j++){
    if(i%j==0){
        return 0;
    }

}
   return 1;
}

int main()
{int T;
cin>>T;
while(T--){
    int n,m;

    cin>>n>>m;
    int r;
    cin>>r;

    int rx[10000]={false};
    int tem;
    for(int i=0;i<r;i++){
    cin>>tem;
    rx[tem]=1;
    }
    int s;
    cin>>s;
    int sx[10000]={0};
    for(int i=0;i<s;i++){
        cin>>tem;
        sx[tem]=true;
    }

    int q;
    cin>>q;

    string tems;
    map<string,int> qx;
    for(int i=0;i<q;i++){
        cin>>tems;
        cin>>tem;
        qx[tems]=tem;
    }
    map<string,double> name;
    char sex;
    int p,c;
    string team;
    for(int i=0;i<n;i++){
        cin>>tems;
        name[tems]=0;
        cin>>team;
        if(qx[team]==1){
           name[tems]+=36;

        }
        if(qx[team]==2){
           name[tems]+=27;

        }if(qx[team]==3){
           name[tems]+=18;

        }
        cin>>sex;
        if(sex=='F'){
            name[tems]+=33;
        }
        cin>>p>>c;
        int rank[1001];
        for(int j=0;j<p;j++){
            cin>>tem;
            if(rx[tem]==1){
                name[tems]+=2.5;
            }else if(sx[tem]==1){
                name[tems]+=1.5;
            }
            else if(is_p(tem)){
              name[tems]+=1;
            }else{
            name[tems]+=0.3;
            }
        }
        for(int j=0;j<c;j++){
            cin>>rank[j];
        }
        sort(rank,rank+c);
        name[tems]+=rank[c-3]>1200?((((double)rank[c-3]-1200.0)/100)*1.5):0;

    }
map<string,double>::iterator iter22;

 for(iter22 = name.begin(); iter22 != name.end(); ++iter22)
 {

  //cout<<iter22->first<<"  "<<iter22->second<<endl;
  //printf("%c %lf",iter22->first,iter22->second);
 }

 vector<PAIR> pair_vec;
 for (map<string, double>::iterator map_iter = name.begin(); map_iter != name.end(); ++map_iter)
{
pair_vec.push_back(make_pair(map_iter->first, map_iter->second));
}
sort(pair_vec.begin(), pair_vec.end(), cmp);
int i=0;
for (vector<PAIR>::iterator curr = pair_vec.begin(); curr != pair_vec.end()&&i<m; ++curr,++i)
{
    cout <<setiosflags(ios::fixed);
cout<< curr->first << " " << setprecision(3)<< curr->second << endl;

}

}

    return 0;
}

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注