Doing Homework HDU – 1074 【状压DP】解题报告

作者: qwq 分类: ACM 发布时间: 2018-07-31 17:35
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
OutputFor each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math


        

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

        

 

这道题目的大意是有n个任务,每个任务有一个截止时间,超过截止时间一天,要扣一个分。
求如何安排任务,使得扣的分数最少。

而数据范围只有15,非常小。说明这是一道NP问题。

而一个最朴实的想法就是枚举所有的做作业的排列顺序,一共15!种可能性。

另外可以想到的是,

对于每个作业,对应着写完与没有写两个情况,一共15种作业,一共具有2^15种状态。正好可以存储在一个int变量里面。

我们把某个作业写完标记为1,没有写完标记为0.

最开始的状态就是所有的作业都没有开始写,可以用00000000来表示。

而结束的状态是所有的作业都写完了,这时候可以用1111111111来表示。

 

而状态的转移就是对于任意一种状态x[例如:0101010110],

可以枚举,该状态是由哪个状态转移而来的,即枚举是做了哪一个作业之后才达到了这个状态。

$$dp[x]=min(dp[x^(1<<i)]+(做第i作业所产生的罚时))(x^(1<<i)为没有做该作业之前的状态)$$

然后需要保存一下某个状态的父状态来输出具体的科目。

/*build at 2018/7/31 16:42   #jetbrains #CLion*/
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>

#define  inf (1<<31-1)
using namespace std;

typedef long long ll;
struct {
    char name[100];
    int e;
    int t;
} a[20];
struct {
   int name;
    int pre;
    int tot;
    int score;
} dp[1 << 16];

int main() {
    ios::sync_with_stdio(0);
    int t;
    cin >> t;
    while (t--) {
        int n;
        cin >> n;
        memset(dp, 0, sizeof(dp));

        for (int i = 0; i < n; i++) {
            cin >> a[i].name >> a[i].e >> a[i].t;
        }
        int x = 1 << n;
        for (int i = 1; i < x; i++) {
            dp[i].score = inf;
            for (int j = n - 1; j >= 0; j--) {
                if ((1 << j) & i) {
                    if (dp[i].score >
                        dp[i - (1 << (j))].score +
                        ((dp[i - (1 << (j))].tot + a[j].t - a[j].e) > 0 ? (dp[i - (1 << (j))].tot + a[j].t - a[j].e)
                                                                        : 0)) {
                        dp[i].score =
                                dp[i - (1 << (j))].score +
                                ((dp[i - (1 << (j))].tot + a[j].t - a[j].e) > 0 ? (dp[i - (1 << (j))].tot + a[j].t -
                                                                                   a[j].e) : 0);
                        dp[i].tot = dp[i - (1 << (j))].tot + a[j].t;
                        dp[i].name = j;
                        dp[i].pre =i - (1 << (j));
                    }
                }
            }

        }

cout<<dp[x-1].score<<endl;
int tt=x-1;
stack<int> xx;
while(tt){
    xx.push(dp[tt].name);
    tt=dp[tt].pre;
}
while(!xx.empty()){
    int now=xx.top();
    xx.pop();
    cout<<a[now].name<<endl;
}
    }
    return 0;
}

 

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注