Nearest Common Ancestors UVALive – 2525 (倍增计算LCA)

作者: qwq 分类: ACM 发布时间: 2017-10-22 20:26

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge –the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N – 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

 

这个题算是一个LCA(最近公共祖先)的模板题了。

我这里使用白书上说的基于二分搜索的LCA算法来处理。

首先是先输入数据,这里使用vector数组来存储每个点的出边。

并把目标点用vis数组标记。这样只要遍历到某个点的vis==0就说明这个点没有入边,这个点就是root点。

然后对根节点进行dfs,在dfs的时候记录每个节点的深度和父节点。

dfs完成之后,就要开始计算距离这个节点为2的祖父几点,以及距离为4的祖先节点,距离为8的祖先节点。。。。

公式是

 

for(int i = 1; i < 21; i++) {
	for (int j = 1; j <= n; ++j) {
		g[i][j] = g[i - 1][g[i - 1][j]];//g[i][j]存储的是距离j节点为2^i的祖先节点的编号
	}
}

然后就可以进行LCA计算了。

首先是比较两个节点的深度,然后统一为x比y深。

dep[x]-dep[y]就是两个节点的深度差。

然后将a节点向上回溯dep[x]-dep[y]个节点,即回退到与y节点深度相同的那个节点。

然后进行二分判断两个节点的g[x][j]和g[y][j],最后找到两个节点的LCA。

 

代码

#include <iostream>
#include<vector>
#include<cstring>
using namespace std;
vector<int >a[20003];
int vis[10003];
int g[21][10003];
int dep[10003];
void dfs(int x, int de) {
	for (int i = 0; i < a[x].size() ; ++i) {

		if(!dep[a[x][i]]) {
			g[0][a[x][i]] = x;
			dep[a[x][i]] = de + 1;
			dfs(a[x][i], de + 1);
		}

	}

}
int lca(int x, int y) {
	if(dep[x] < dep[y]) {
		swap(x, y);
	}
	int t = dep[x] - dep[y];
	for(int i = 0; i < 21; i++) {
		if((1 << i)&t) {

			x = g[i][x];

		}
	}
	if(x == y) {
		return x;
	}
	for (int i = 20; i >= 0 ; i--) {
		if(g[i][x] != g[i][y]) {
			x = g[i][x];

			y = g[i][y];
		}
	}

	return g[0][x];


}



int main() {
	int t;
	cin >> t;
	int n;
	while(t--) {
		memset(vis, 0, sizeof(vis));
		memset(g, 0, sizeof(g));
		memset(dep, 0, sizeof(dep));
		for (int i = 0; i < 10003; ++i) {
			a[i].clear();
		}

		cin >> n;
		int t1, t2;
		for (int i = 1; i < n; ++i) {
			cin >> t1 >> t2;
			a[t1].push_back(t2);
			vis[t2] = 1;
		}
		cin >> t1 >> t2;
		for (int i = 1; i <= n; ++i) {
			if(vis[i] == 0) {
				dfs(i, 1);
			}
		}
		for(int i = 1; i < 21; i++) {
			for (int j = 1; j <= n; ++j) {
				g[i][j] = g[i - 1][g[i - 1][j]];
			}
		}
		cout << lca(t1, t2) << endl;


	}





	return 0;
}

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注