Charm Bracelet POJ – 3624 (01背包问题)
Version:1.0 StartHTML:000000193 EndHTML:000002773 StartFragment:000000845 EndFragment:000002715 StartSelection:000000845 EndSelection:000002715 SourceURL:http://poj.org/problem?id=36243624 — Charm Bracelet
Charm Bracelet
Description Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 鈮?N 鈮?3,402) available charms. Each charm i in the supplied list has a weight Wi (1 鈮?Wi 鈮?400), a ‘desirability’ factor Di (1 鈮?Di 鈮?100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 鈮?M 鈮?12,880). Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings. Input * Line 1: Two space-separated integers: N and M Output * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints Sample Input 4 6 1 4 2 6 3 12 2 7 Sample Output 23 Source |
题目很简单,就是01背包的基础题目。用动态规划就可以做。
#include<iostream>
using namespace std;
struct charm{
int w;
int v;
}a[3505];
int max2(int a,int b){
if(a>b)
return a;
return b;
}
int main(){
int n,m;
cin>>n>>m;
for(int i=1;i<=n;i++){
cin>>a[i].w>>a[i].v;
}
int f[12890]={0};
for(int i=1;i<=n;i++){
for(int j=m;j>=a[i].w;j--){
f[j]=max2(f[j],f[j-a[i].w]+a[i].v);
}
}
cout<<f[m]<<endl;
return 0;
}