Just a Hook HDU – 1698 (线段树的区间更新)

作者: qwq 分类: ACM 发布时间: 2017-09-19 19:52
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

Sample Input
1 10 2 1 5 2 5 9 3

 

Sample Output
Case 1: The total value of the hook is 24.
这个题算是线段树的模板题了吧
#include<iostream>
#include<cstring>

using namespace std;
int a[600000];
int lazy[600000];
int n,o;
int nx;
void  build(int n,int l,int r){
//	cout<<l<<r<<endl;
	if(l==r){
		if(l<=nx){
			a[n]=1;
		}else{
			a[n]=0;
			
		}
	}
	
	
	else{
		build(n<<1,l,(l+r)/2);
		build(n<<1|1,(l+r)/2+1,r);
		a[n]=a[n<<1]+a[n<<1|1];
	}
	
}
void update(int n,int l,int r,int L,int R,int s){

	if(l>=L&&r<=R){
		a[n]=(r-l+1)*s;
		lazy[n]=s;
		
	}else{
		if(lazy[n]){
			update(n<<1,l,(l+r)/2,l,r,lazy[n]);
			update(n<<1|1,(l+r)/2+1,r,l,r,lazy[n]);
			lazy[n]=0;
		}
	
		if(L<=(l+r)/2)	
		update(n<<1,l,(l+r)/2,L,R,s);
		if(R>(l+r)/2)
		update(n<<1|1,(l+r)/2+1,r,L,R,s);
	a[n]=a[n<<1]+a[n<<1|1];
		
	}
}
int main(){
	ios::sync_with_stdio(0);
	int T;
	cin>>T;
	int cas=1;
	while(T--){
	memset(a,0,sizeof(a));
	memset(lazy,0,sizeof(lazy));
		
cin>>n>>o;
nx=n;
int k=1;
while(k<n){
	k=k<<1;
}

int l,r,q;
//cout<<k;
build(1,1,k);

for(int i=0;i<o;i++){
	cin>>l>>r>>q;
	update(1,1,k,l,r,q);
}		
		
		cout<<"Case "<<cas++<<": The total value of the hook is "<<a[1]<<"."<<endl;
		
	}
	
} 

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注