Cable master (深坑)

作者: qwq 分类: ACM 发布时间: 2017-07-13 15:15

 

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology – i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

 

这个题看着挺简单,但是实际写的时一直WA到怀疑人生

这个题第一个比较坑的地方是它实际是有多组测试数据,所以必须得加上一个while();

第二个是printf必须要用%f,和scanf不一样,它不支持%lf

第三个就是也不要用cin cout 因为会超时,也不要开加速。

其余的话就是简单的二分法,还是不难的

 

#include<iostream>
#include<cstdio>

using namespace std;
double len[100001];
int n,k;
int judge(double x){
	int sum=0;
	for(int i=0;i<n;i++){
		sum+=(int)(len[i]/x);
	}
	if(sum>=k){
		return 1;
	}
	return 0;
}

int main(){
//	ios::sync_with_stdio(false);
while(~scanf("%d%d",&n,&k)){
	
	double max =-1;
	for(int i=0;i<n;i++){
		scanf("%lf",&len[i]);
		max=max>len[i]?max:len[i];
	}
	double l,r;
	l=0.0;
	r=max;
	double mid=(l+r)/2;
	for(int i=0;i<100;i++){

		mid=(l+r)/2;
		if(judge(mid)){
			l=mid;
		}else{
			r=mid;
		}
	}
	//printf("%lf\n",r);
	int rx=r*100;
	double rr=rx/100.0;
		printf("%.2f",rr);
}
	return 0;}

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注