Wireless Network POJ – 2236 (并查集)

作者: qwq 分类: ACM 发布时间: 2017-04-23 22:58

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCES

这道题不难,就是并查集的使用。

先用结构体接收输入的数据。

然后如果输入的数据是O,就修理电脑,把电脑状态的is_ok设置为1.从0开始遍历一遍各个电脑,如果该电脑的is_ok

状态也是1,就检查两台电脑是不是可以联网,如果是就merge两个并查集。

如果输入是S,就查看两个电脑的father是不是相同,如果相同就代表可以连接。

#include<iostream>
using namespace std;
int N,d;
struct computer{
	int x;
	int y;
	int father;
}aa[1002];
int is_ok[1002];
int find(int a){
int y=a;
while(aa[y].father!=y){
	y=aa[y].father;
} 
return y;
} 
void merge(int a,int b){
	int ra=find(a);
	int rb=find(b);
	if((aa[a].x-aa[b].x)*(aa[a].x-aa[b].x)+(aa[a].y-aa[b].y)*(aa[a].y-aa[b].y)<=d*d){
		aa[rb].father=ra;
	}
}

int main(){
	
	for(int i=0;i<1002;i++)
	aa[i].father=i;
	cin>>N>>d;
	char c;
	int m,n; 
for(int i=1;i<=N;i++){
	cin>>aa[i].x>>aa[i].y;
}	
	while(cin>>c){
		if(c=='O'){
			cin>>m;
			is_ok[m]=1;
			for(int i=1;i<=N;i++){
				if(is_ok[i])
				merge(i,m);
				
			}
			 
		}
		if(c=='S'){
		cin>>m>>n;
		//cout<<find(m)<<find(n)<<endl;
		if(find(m)==find(n)){
			cout<<"SUCCESS"<<endl; 
		}else{
			cout<<"FAIL"<<endl; 
		}	
			
			
		}
		
		
		
	}
	return 0;
} 

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注