5-1 到底有多二 (15分)

作者: qwq 分类: ACM,天梯赛 发布时间: 2017-03-22 18:31

最简单的题了,注意输出的时候printf中要输出%号的话需要是%%

一个整数“犯二的程度”定义为该数字中包含2的个数与其位数的比值。如果这个数是负数,则程度增加0.5倍;如果还是个偶数,则再增加1倍。例如数字-13142223336是个11位数,其中有3个2,并且是负数,也是偶数,则它的犯二程度计算为:3/11\times 1.5\times 2\times 100\%3/11×1.5×2×100%,约为81.82%。本题就请你计算一个给定整数到底有多二。

输入格式:

输入第一行给出一个不超过50位的整数N

输出格式:

在一行中输出N犯二的程度,保留小数点后两位。

输入样例:

-13142223336

输出样例:

81.23%

[code lang="c"]
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
int main(){
ios::sync_with_stdio(false);
string s;
cin>>s;
double a,b=1;
int len=s.length();
if(s[0]=='-')
b=1.5*b;
if((s[len-1]-'0')%2==0)
b+=b;
int num=0;
for(int i=0;i<len;i++){
if(s[i]=='2')
num++;
}
printf("%.2lf%%",s[0]=='-'?(((double)num)/(len-1)*100*b):(((double)num)/len*100*b));

return 0;
}
[/code]

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注